728x90
바로가기 : JAVA 풀이 C언어 풀이 Python 풀이
링크 : https://www.acmicpc.net/problem/1330
문제
두 정수 A와 B가 주어졌을 때, A와 B를 비교하는 프로그램을 작성하시오.
입력
첫째 줄에 A와 B가 주어진다. A와 B는 공백 한 칸으로 구분되어져 있다.
출력
첫째 줄에 다음 세 가지 중 하나를 출력한다.
- A가 B보다 큰 경우에는 '>'를 출력한다.
- A가 B보다 작은 경우에는 '<'를 출력한다.
- A와 B가 같은 경우에는 '=='를 출력한다.
예제 입력 1
1 2
예제 출력 1
<
예제 입력 2
10 2
예제 출력 2
>
예제 입력 3
5 5
예제 출력 3
==
JAVA 풀이
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int a = sc.nextInt();
int b = sc.nextInt();
if(a < b)
System.out.print("<");
else if(a > b)
System.out.print(">");
else if(a == b)
System.out.print("==");
}
}
C언어 풀이
#include <stdio.h>
int main()
{
int a, b;
scanf("%d %d", &a, &b);
if (a < b)
printf("<");
else if (a > b)
printf(">");
else if (a == b)
printf("==");
return 0;
}
Python 풀이
a, b = map(int, input().split())
if a < b:
print('<')
elif a > b:
print('>')
elif(a == b):
print("==")
728x90